

<!DOCTYPE html>
<html xmlns:fb="http://www.facebook.com/2008/fbml" xmlns:og="http://opengraph.org/schema/">
<head>
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
  <meta http-equiv="Content-Language" content="en-AU">
  




<meta property="og:title" content="3 ways to use data, analytics and machine learning in test automation" />
<meta property="og:type" content="article" />
<meta property="og:image" id="shareimage1" content="https://d1abomko0vm8t1.cloudfront.net/article/images/600x315/dimg/analytics_dreamstime.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="315" />
<meta property="og:url" id="shareurl"content="https://www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/" />
<meta property="og:description" content="Better testing means better software. Using NLP, test data generation, and optimised testing can quickly improve applications." />
<meta property="og:image" id="shareimage2" content="https://d1abomko0vm8t1.cloudfront.net/article/images/180x110/dimg/analytics_dreamstime.jpg" />
<meta property="og:image:width" content="180" />
<meta property="og:image:height" content="110" />



<!-- The below is the code for twitter cards for all the article pages -->






<meta name="news_keywords" content="machine learning, analytics, data, Automation.">



<link rel="canonical" href="https://www.infoworld.com/article/3636217/3-ways-to-use-data-analytics-and-machine-learning-in-test-automation.html" />


<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20211021182430" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/article.css?release=20211021182430" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/comment.css?release=20211021182430" media="all" rel="stylesheet" type="text/css">
<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/social.css?release=20211021182430" media="all" rel="stylesheet" type="text/css">

<link rel="alternate" type="application/rss+xml" title="Reseller News: machine learning" href="/rss/tag/machine-learning/" />

<link rel="alternate" type="application/rss+xml" title="Reseller News: analytics" href="/rss/tag/analytics/" />

<link rel="alternate" type="application/rss+xml" title="Reseller News: data" href="/rss/tag/data/" />

<link rel="alternate" type="application/rss+xml" title="Reseller News: Automation." href="/rss/tag/automation_2/" />

<link rel="alternate" type="application/rss+xml" title="Reseller News: by Isaac Sacolick" href="/rss/author/2147449269/isaac-sacolick/" />





<link href="https://www.idgcdn.com.au/compressor-staticfiles/social_login_sass.css?release=20211021182430" rel="stylesheet" type="text/css" />

<link href="https://www.idgcdn.com.au/compressor-staticfiles/article/magnific-popup.css?release=20211021182430" media="all" rel="stylesheet" type="text/css">
<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/article/article_infinite.css?release=20211021182430" />

<link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/arn/style.css?release=20211021182430" />
<link rel="stylesheet" type="text/css" media="all" href="https://www.idgcdn.com.au/compressor-staticfiles/polls/polls.css?release=20211021182430" />

  <meta name="abstract" content="The Newspaper for the IT Channel.">
  <meta name="description" content="Better testing means better software. Using NLP, test data generation, and optimised testing can quickly improve applications.">
  <meta name="keywords" content="machine learning, analytics, data, Automation.">

  <meta name="copyright" content="&copy; 2021 IDG Communications">
  <meta name="resource-type" content="document">
  <meta name="date" content="Thursday, 21st October 2021">
  <meta name="robots" content="index,follow, noarchive">
  <meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no, minimum-scale=1.0, maximum-scale=1.0">
  <link rel="shortcut icon" href="https://demo.idg.com.au/nzreseller/favicon.ico">
  <title>3 ways to use data, analytics and machine learning in test automation - Reseller News</title>
  <!--[if lt IE 9]>
  <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->
<!--   <script src='//twin-iq.kickfire.com/twin.js?14992'></script>-->
  <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"></script>

  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/arn/webfonts-proxima-nova.css?release=20211021182430" media="screen,print" />
  <link href="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.css?release=20211021182430" rel="stylesheet" type="text/css" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/jobs/jobbox.css?release=20211021182430" media="screen,print" />
  <link rel="stylesheet" type="text/css" href="https://www.idgcdn.com.au/compressor-staticfiles/brand_posts/style.css?release=20211021182430" media="screen,print" />
  <link href="https://www.idgcdn.com.au/compressor-staticfiles/arn_zones/nextdc_hub/slick.css?release=20211021182430" rel="stylesheet" type="text/css" />
  <link href="https://www.idgcdn.com.au/compressor-staticfiles/nzreseller/reseller.css?release=20211021182430" rel="stylesheet" type="text/css" />
    

<!--start Sourcepoint code-->

<script type="text/javascript">
    !function () { var e = function () { var e, t = "__tcfapiLocator", a = [], n = window; for (; n;) { try { if (n.frames[t]) { e = n; break } } catch (e) { } if (n === window.top) break; n = n.parent } e || (!function e() { var a = n.document, r = !!n.frames[t]; if (!r) if (a.body) { var i = a.createElement("iframe"); i.style.cssText = "display:none", i.name = t, a.body.appendChild(i) } else setTimeout(e, 5); return !r }(), n.__tcfapi = function () { for (var e, t = arguments.length, n = new Array(t), r = 0; r < t; r++)n[r] = arguments[r]; if (!n.length) return a; if ("setGdprApplies" === n[0]) n.length > 3 && 2 === parseInt(n[1], 10) && "boolean" == typeof n[3] && (e = n[3], "function" == typeof n[2] && n[2]("set", !0)); else if ("ping" === n[0]) { var i = { gdprApplies: e, cmpLoaded: !1, cmpStatus: "stub" }; "function" == typeof n[2] && n[2](i) } else a.push(n) }, n.addEventListener("message", (function (e) { var t = "string" == typeof e.data, a = {}; try { a = t ? JSON.parse(e.data) : e.data } catch (e) { } var n = a.__tcfapiCall; n && window.__tcfapi(n.command, n.version, (function (a, r) { var i = { __tcfapiReturn: { returnValue: a, success: r, callId: n.callId } }; t && (i = JSON.stringify(i)), e.source.postMessage(i, "*") }), n.parameter) }), !1)) }; "undefined" != typeof module ? module.exports = e : e() }();
</script>

<script>
        window._sp_ = {
                config: {
                     accountId: 146,
                     baseEndpoint: 'https://cmpv2.reseller.co.nz' ,
        }
}
</script>
<script src="https://cmpv2.reseller.co.nz/wrapperMessagingWithoutDetection.js"></script>
<!--end Sourcepoint code-->



	<script>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</script>

		<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
		<body>
		<script type="text/javascript">(function(){window['__CF$cv$params']={r:'681941c429355557',m:'dc10cc25a96508c5b5bc648ca5ffcb415a94a508-1629437713-1800-AbnxjWixxfW9ufQu9yaF4Z4+8ipQi9zUVtKJyLaleeIT+9mUHAO/ya71cyuI7big8WNZdRvtm5lr+x16UhgJY8v6oGnjm1NF980i4xGpHN4UnAHAZ7Aw+VBYnFUEKsA6mCvC6987Vm1jod0aPbI5WMk=',s:[0x6107d02fa0,0x03a9d30f70],}})();</script></body>
		<script>
		//copy this whole script block
		//if no cmp then execute as normal.
		window.idguk = window.idgau || {};
		window.idguk.cmp = window.idgau.cmp || {};

		(function(promise){
			promise.then(function(consentOk){
				const isDebug = !!window.idguk.cmp.isDebug ? window.idguk.cmp.isDebug() : false;
				if(isDebug)console.log('GDPR','kickfire - consentOk', consentOk);
				if(!consentOk)return;
				const ID = 14992;
				let atsScript = document.createElement('script');
				atsScript.src = '//twin-iq.kickfire.com/twin.js?'+ID;
				atsScript.async=!0
				document.body.appendChild(atsScript);
			});

		})(
			!!window.idguk.cmp.kickfire ? window.idguk.cmp.kickfire : {then:function(f){f(true);}}
		);
		</script>

<script>

function runTracking() {
      var detectClarityExist = setInterval(function () {
        //waiting until tracking exist
        if (clarity_tracking_starter) {
          clarity_tracking_starter();
          clearInterval(detectClarityExist);
        }
      }, 10)
} 

runTracking();

</script> 
 
  <script async src="//js-sec.indexww.com/ht/p/183980-91716487582353.js"></script>  
  <script src="https://cdn.blueconic.net/idg.js"></script>
  <script type='text/javascript'>
  (function(w,d,s,src){var tag = d.createElement(s);var lastScript = d.getElementsByTagName(s)[0];tag.async = 1;tag.src = src;tag.setAttribute("data-cfasync","false");lastScript.parentNode.insertBefore(tag, lastScript);})(window, document, 'script', 'https://intent.reseller.co.nz/analytics.js');
</script>
  <script src="https://www.google.com/recaptcha/api.js"></script>
  
  
<meta property="fb:app_id" content="105374282841262" />
<meta property="og:site_name" content="Reseller News" />


  <!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');

fbq('init', '1724434721147660');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1724434721147660&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->

  



<script src="https://www.idgcdn.com.au/compressor-staticfiles/permutive/adsbygoogle.js?release=20211021182430"></script>
<script>

  var adblockerOn;
  if( typeof canRunAds != "undefined" && canRunAds ){
    adblockerOn = false;
  }else{
    adblockerOn = true;
  }

  function getMetaDescription(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='description'){
          return (metas[i].getAttribute('content'));
        }
    }
    return ''
  }

  function getMetaKeywords(){
    var metas = document.querySelectorAll('meta')
    for(var i=0;i<metas.length;i++){
        if(metas[i].getAttribute('name')==='keywords'){
          var newStr = (metas[i].getAttribute('content'));
          return newStr.split(',');
        }
    }
    return []
  }

  !function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
  permutive.addon('web', {
    page: {
      type: "article",
      keywords: getMetaKeywords(),
      language: "en",
      tags: ['machine learning', 'analytics', 'data', 'Automation.'],
      audience: "channel",
      description: getMetaDescription(),
      article: {
        authors: "Isaac Sacolick" === "None"?null:["Isaac Sacolick"],
        description: "Better testing means better software. Using NLP, test data generation, and optimised testing can quickly improve applications." === "None"?null:"Better testing means better software. Using NLP, test data generation, and optimised testing can quickly improve applications.",
        id: "692260" === "None"?null:"692260",
        isInsiderContent: false,
        modifiedAt: "2021-10-18T21:02:38Z" === "None"?null:"2021-10-18T21:02:38Z",
        publishedAt: "2021-10-19T05:45:00Z" === "None"?null:"2021-10-19T05:45:00Z",
        source: "Reseller News",
        title: "3 ways to use data, analytics and machine learning in test automation",
        type: "Article" === "None"?null:"Article",
        purchaseIntent: "None" === "None"?null:"None"
      },
      ads: {
        adblocker: adblockerOn,
        enabled: true
      },
      gTax: {
        primaryIds: [],
        secondaryIds: []
      },
      tax: {
        primaryCategories: [],
        secondaryCategories: []
      }
    }
  });

window.permutive.track('User', {
  companySize: "None" === "None"?null:"None",
  country: "None" === "None"?null:"None",
  id: "None" === "None"?null:"None",
  jobIndustry: "None" === "None"?null:"None",
  jobPosition: "None" === "None"?null:"None",
  purchaseIntent: "None" === "None"?null:"None",
  loggedIn: false,
})

</script>
<script async src="https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js"></script>




</head>
<body class="arn nzreseller lo-responsive  twocolumns_noLHS">

<header id="lo-header" class="lo-header" role="banner">
  <div class="lo-header_top">
    <div class="logo-warp">
      
      <a href="/" id="lo-logo" class="lo-logo">Reseller News</a>
      
    </div>
    <div class="lo-leaderboard">
<div class="gpt-ad" id="gpt-ad-top-banner-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>

    <div class="lo-nav_button" id="lo-nav_button"></div>
  </div>
  <nav class="lo-nav" id="lo-nav">
    <ul>
      <li class="search">
        <form action="/search/" method="get">
          <input type="search" placeholder="Search" name="q" class="text">
          <input type="submit" name="op" value="Submit">
        </form>
      </li>
      <li>
        <a href="/tax/news">News</a>
      </li>
      <!--<li>
        <a href="/advance/">Advance</a>
      </li>-->
      <li class="super">
        <a href="#">ANALYSIS</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/tax/analysis">Analysis</a></li>
                <li><a href="/tax/profiles/">Profiles</a></li>
                <li><a href="/podcast/">Podcasts</a></li>
                <li><a href="/tax/executive_roundtables/">Executive Roundtables</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">ECOSYSTEM</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
            <ul>
                <li><a href="/distributor_directory/">Distributor Directory</a></li>
                <li><a href="/vendor_directory/">Vendor Directory</a></li>
                <li><a href="/slideshow/">Gallery</a></li>
             </ul>
            </div>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="/events/upcoming/">Events</a>
        <div class="lo-nav_sub events">
          <div class="inner">
            <div class="placeholder" data-placeholder="sub_events_hotevents"></div>
            <div class="placeholder" data-placeholder="sub_events_latest"></div>
            <a class="lo-nav_more" href="/events/upcoming/">View all events</a>
          </div>
        </div>
      </li>
      <li class="super">
        <a href="#">Content Hub</a>
        <div class="lo-nav_sub resources">
          <div class="inner">
            <div class="main lo-nav_submenu">
              <ul>
                <li><a href="/brand-post/">Brand Posts</a></li>
                <li><a href="/microsites">Microsites</a></li>
              </ul>
              <ul>
                <li><a href="/webinar/">Webinars</a></li>
                <li><a href="/section/featured_whitepapers">Reseller News Library</a></li>
              </ul>
              <ul>
                <li><a href="/mediareleases/">Media Releases</a></li>
                <li><a href="/user/mailing_list">Subscribe online</a></li>
              </ul>
            </div>
          </div>
        </div>
      </li>
   
      <li>
        <a href="/contacts/">Contact</a>
      </li>
     <!-- <li class="nav-tab-large-screen">
        <a href="/award_winners/reseller-ict-industry-awards-2019/2019/">Platinum Club</a>
     </li>-->
      <li class="user super">
        
          <a href="#">Sign In</a>
        
        <div class="lo-nav_sub user">
          <div class="inner">
            
            <section class="existing">
              <h2>Existing Member</h2>
              <form action="/user/login/" accept-charset="UTF-8" method="get"><input type='hidden' name='csrfmiddlewaretoken' value='Epsn2ilLcZkszwFB3h02ygNIKlqWbkObEZhTogO55mg44idZW1cP4IrNfG7tMbu0' />
                <input type="submit" name="op" value="Log in">
                <p class="forgot"><a href="/user/password/">Forgot password?</a></p>
              </form>
            </section>
            <section class="join">
              <h2>Join Reseller News</h2>
              <p>Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.</p>
              <a href="/user/register/?location=top_nav_bar">Sign up now</a>
            </section>
            
          </div>
        </div>
      </li>
      <!--<li>
        <a href="/covid19/">Covid-19 Central</a>
      </li>-->
    </ul>
  </nav>
</header>

<div id="skin" class="cfix">
<div id="headerpromos"></div>
<div id="otp_target"></div>
<div id="noskin_bump" class="lo-skin_bump"></div>


<div id="main" class="lo-content skin_wrap">
<div class="lo-columns " id="site_columns">

  
    
    
    
     
  

<div id="site_columns">
  

  
  <div class="lo-column lo-main    " id="site_columns_main">
    
<div id="art-articles_wrap" class="art-articles_wrap art-articles_wrap_infinite">

  <div class="art-topbar" id="art-topbar">
    <div class="art-topbar_content">
      <a id="art-topbar_menu_button_arn" class="art-topbar_menu_button" href="#">Menu</a>

      <a class="art-topbar_logo" href="/">ARN</a>
      <div class="art-progress" id="art-progress">
        <div class="art-topbar_currect" id="art-topbar_currect">
          3 ways to use data, analytics and machine learning in test automation
        </div>
        <div class="art-next" id="art-next">
          <a class="art-nextlink" id="art-nextlink" href="#"></a>
        </div>
      </div>
    </div>
    <div class="art-progress_bar" id="art-progress_bar"></div>
  </div>

  <div id="art-next_signifier" class="art-next_signifier">
    <div class="art-next_signifier_content">
      <span class="art-next_signifier_image" id="art-next_signifier_image"></span>
      <h3 class="art-next_signifier_title" id="art-next_signifier_title"></h3>
    </div>
  </div>


  

  <div itemscope itemtype="http://schema.org/Article" class="art-wrap article_wrap" id="article_wrap_692260" data-article-id="692260" data-article-headline="3 ways to use data, analytics and machine learning in test automation" data-article-url="/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">

    <meta itemprop="sourceOrganization" content="InfoWorld" />
    <article class="art-article full">

      <header class="art-header">
        <h1 itemprop="name" class="art-title">3 ways to use data, analytics and machine learning in test automation</h1>
        <p class="art-sms sms">Better testing means better software. Using NLP, test data generation, and optimised testing can quickly improve applications.</p>

        
        

        
        



<div class="art-social article_social" id="article_social_0" data-article-id="692260" data-article-url="https://www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">
	<div class="art-byline art-byline_withpic">

		
			<a class="art-author_pic" href="/author/2147449269/isaac-sacolick/articles">
			
				<img src="https://d1abomko0vm8t1.cloudfront.net/author/100x100/authors/1280px-idg_logo-1svg_20.png" alt="Isaac Sacolick">
			
			</a>
		

		<span class="art-author">
		
      <!-- Condition to display the Channel Asia instead of Channel Asia Singapore for the authors on Channel Asia sites -->
			<a href="/author/2147449269/isaac-sacolick/articles">Isaac Sacolick (InfoWorld)</a>
		
		</span>

		
			<span class="art-date" itemprop="datePublished">19 October, 2021 05:45</span>
		
	</div>

	<ul class="art-share">
		<!-- <li class="comments_li"><a class="comments" href="#comments" data-disqus-identifier="/article/692260/">0</a></li> -->
		<li class="facebook_li"><a data-action="Like" data-label="Facebook" target="_blank" class="facebook" href="http://www.facebook.com/sharer.php?u=https%3A//www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/&amp;amp;t=3%20ways%20to%20use%20data%2C%20analytics%20and%20machine%20learning%20in%20test%20automation"></a></li>
		<li class="linkedin_li">
			<a data-action="share" data-label="LinkedIn" target="_blank" class="linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A//www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/&amp;title=3%20ways%20to%20use%20data%2C%20analytics%20and%20machine%20learning%20in%20test%20automation">
				<span class="s">share</span>
			</a>
		</li>
		<li class="twitter_li">
			<a data-action="Tweet" data-label="Twitter" target="_blank" class="twitter" href="http://twitter.com/share?text=3%20ways%20to%20use%20data%2C%20analytics%20and%20machine%20learning%20in%20test%20automation&amp;url=https%3A//www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">

			</a>
		</li>
		<!-- <li class="gplus_li">
			<a data-action="+1" target="_blank" data-label="Google+" class="gplus" href="https://plus.google.com/share?url=https%3A//www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">
			
			</a>
		</li> -->
		
		<li class="print_li">
			<a class="line print" title="print this article" href="/article/print/692260/3-ways-use-data-analytics-machine-learning-test-automation/" rel="nofollow">
				print
			</a>
		</li>
		
		<li class="email_li">
			<a class="line email" title="email this article" href="mailto:?subject=3%20ways%20to%20use%20data%2C%20analytics%20and%20machine%20learning%20in%20test%20automation&amp;amp;body=https%3A//www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">
				email
			</a>
		</li>
	</ul>
</div>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/social.js?release=20211021182430"></script>
<script>
// var social_float_disable = true;
</script>

        

        
        


        <div class="art-header_extra">
          
          


          <a href="#art-comments_692260" data-disqus-identifier="/article/692260/" class="art-comment_count">Comments</a>
        </div>

      </header>

      <div itemprop="articleBody" class="art-body body">

      
      
      
      
      <div class="story_images nocaption">
        <figure>
          
          <img alt="" src="https://d1abomko0vm8t1.cloudfront.net/article/images/740x500/dimg/analytics_dreamstime.jpg">
          

          
          
          <span class="image-license">
            
            <span>Credit:  Dreamstime </span>
            
            
          </span>
          

        </figure>
        

        
      </div>
      
      
      



      

      













	
<p>Just 10 years ago, most application development testing strategies focused on unit testing for validating business logic, manual test cases to certify user experiences, and separate load testing scripts to confirm performance and scalability.</p><p>The development and release of features were relatively slow compared to today’s development capabilities built on cloud infrastructure, microservice architectures, continuous integration and continuous delivery (CI/CD) automations, and <a href="https://www.infoworld.com/article/3565175/defining-a-continuous-testing-strategy.html" target="_blank">continuous testing capabilities</a>.</p><p>Furthermore, many applications are developed today by configuring software as a service (SaaS) or building <a href="https://www.infoworld.com/article/3618059/7-keys-to-selecting-a-low-code-platform.html" target="_blank">low-code and no-code applications</a> that also require testing the underlying business flows and processes.</p>
<div style="line-height:0;z-index:2000;position:relative">
<div class="gpt-ad" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-size-mapping="[[[0, 0], [[3, 3]]]]" data-gpt-sizes="[[3, 3]]" data-gpt-targeting='{"node": ["692260"], "idgau_tax": ["news"], "site": ["nzrn"], "sect": ["software"], "idgau_search_referrer": ["no"], "type": ["article"]}' id="gpt-ad-interscroller-608235">
</div>
<div class="house-slot" data-min-width="" data-name="" style="display:none">
</div>
</div>
<p><a href="https://www.infoworld.com/article/3626460/5-takeaways-from-recent-agile-and-devops-reports.html" target="_blank">Agile development teams in devops organisations</a> aim to reduce feature cycle time, increase delivery frequencies, and ensure high-quality user experiences. The question is, how can they reduce risks and <a href="https://www.infoworld.com/article/3516013/how-to-improve-cicd-with-shift-left-testing.html" target="_blank">shift-left testing</a> without creating new testing complexities, deployment bottlenecks, security gaps, or significant cost increases?</p><p>Esko Hannula, product line manager at Copado, spoke to me about the recent acquisition of <a href="https://qentinel.com/" rel="nofollow" target="_blank">Qentinel</a> and the testing challenges facing devops organizations. He believes machine learning is key to handling increasing test volumes.</p><p>“The quality of digital business is the quality of the code and testing that runs it. The more code there is to test, the more important it gets to marry machine learning with test automation. QA people and machine intelligence can support each other in making wise decisions based on data rather than a mere gut feeling.”</p><p>I recently wrote about <a href="https://www.infoworld.com/article/3624573/the-benefits-of-api-and-service-virtualization.html" target="_blank">using service virtualisation</a> to develop more robust web service tests when building microservices or interfacing with many third-party APIs. I then looked a step further and researched testing capabilities based on data, analytics, and machine learning that development teams and QA test automation engineers can leverage to develop and support more robust testing.</p><p>These capabilities are emerging, with some testing platforms offering robust functionality today while others are in early adopter phases. Development teams should research and plan for these testing functions as they will all become mainstream capabilities.</p><p><strong>Generating tests using natural language processing</strong></p><p>Test quality has improved significantly during the last decade as QA platforms analyse a webpage’s document object model (DOM), leverage computer vision to detect user interface changes, and utilise optical character recognition to extract text elements.</p><p>But developing tests often requires test engineers to click through user interfaces manually, input data in forms, and navigate workflows while QA platforms record the test case.</p><p>An emerging approach is to use natural language processing (NLP) to document test cases. Sauce Labs recently acquired <a href="https://saucelabs.com/news/sauce-labs-enters-into-definitive-agreement-to-acquire-autonomiq" rel="nofollow" target="_blank">AutonomIQ</a>, a tool that enables users to describe the testing steps in natural language and then their software automatically creates the test cases.</p><p>John Kelly, CTO of Sauce Labs, describes why this capability is important as more organisations develop customer relationship management customisation, business process management workflows, and <a href="https://saucelabs.com/blog/3-challenges-to-overcome-when-implementing-low-code-development" rel="nofollow" target="_blank">low-code applications</a>.</p><p>He describes the experience from a business perspective: “I have internal business processes that subject matter experts can describe in natural language, which NLP machine learning can then convert to test cases that can run as often as desired.</p><aside id="brand-post-promo-placeholder-slot"></aside><p>"I can then demonstrate to outside auditors that controls are followed properly. So, a codeless approach to creating test cases is an emerging way to document and validate business processes.”</p><p><strong>Expanding tests with synthetic test data generation</strong></p><p>Once QA engineers capture test cases, the next task is to generate sufficient test data to validate the underlying business rules and boundary conditions. Test data generation can be particularly challenging for open-ended experiences like search engines, complicated multi-field forms, document uploads, and testing with personally identifiable information or other sensitive data.</p><p>Tools from <a href="https://opentestingplatform.curiositysoftware.ie/test-data-automation" rel="nofollow" target="_blank">Curiosity Software</a>, <a href="https://www.datprof.com/products/datprof-runtime/" rel="nofollow" target="_blank">Datprof</a>, <a href="https://www.delphix.com/solutions/test-data-management" rel="nofollow" target="_blank">Delphix</a>, <a href="https://www.genrocket.com/enterprise-test-data-automation/" rel="nofollow" target="_blank">GenRocket</a>, <a href="https://icedq.com/" rel="nofollow" target="_blank">Torana (iCEDQ)</a>, <a href="https://www.k2view.com/products/test-data-management/" rel="nofollow" target="_blank">K2View</a>, and others provide test data automation capabilities for different applications and data flows, including functional testing, API testing, <a href="https://blogs.starcio.com/2020/08/data-science-dataops-agile.html" rel="nofollow" target="_blank">dataops</a>, data lakes, and business intelligence.</p><p><strong>Optimising continuous testing practices</strong></p><p>Several platforms are looking to help agile development teams and QA automation engineers optimise their testing practices.</p><p>Failure analysis helps development teams research the root causes when tests fail. Kelly describes the challenge: “You have a thousand selenium tests, run them all, and get 300 failures. The team doesn’t know if it’s a broken API or something else and whether the problem will happen in production, knowing the test environment doesn’t fully reflect it. They’re interested in the root causes of test failures. Our models cohort the failed tests and report which tests are related to the same problem.”</p><p>Another challenge is optimising the test suite and determining which tests to run based on a release’s code changes. Testing teams can heuristically design a “smoke test,” a regression test around the essential app functionalities and flows.</p><p>But for devops teams implementing continuous testing, there’s an opportunity to connect the data between tests, code changes, and production systems and apply machine learning to choose which tests to run. Optimising the tests in a build is a much-needed capability for dev teams that release code frequently on mission-critical applications.</p><p>One solution targeting this challenge is <a href="https://yourbase.io/technology/dependency-graph/" rel="nofollow" target="_blank">YourBase</a> which creates a dependency graph that maps test cases with their code paths. When developers change the code, the tool uses the dependency graph to optimise which test cases need to run.</p><p>Yves Junqueira, CEO of YourBase, told me, “We see companies that have tens or even hundreds of thousands of tests. They want to improve their lead time to get code to production and improve developer productivity. These teams must make smart decisions about which tests are really necessary for their changes and want a better understanding of test failures.”</p><p>A third approach operates outside the testing environment and helps device engineers and software developers trace production errors, exceptions, and critical events. <a href="https://backtrace.io/product/" rel="nofollow" target="_blank">Backtrace</a> provides this capability. Development teams use its aggregate error reporting and deduplication analytics to quickly find and resolve issues in gaming, mobile, or other embedded applications.</p><p>The key for devops organisations is recognising that driving frequent releases on more mission-critical applications requires a parallel effort to increase the automation, robustness, and intelligence in testing.</p><p><a href="https://blogs.starcio.com/2021/04/it-digital-operations-aiops.html" rel="nofollow" target="_blank">AIops</a> platforms help IT service management teams support microservices and complex application dependencies by centralising operational data and enabling machine learning capabilities. In a similar manner, QA platforms aim to provide agile development teams with automation, analytics, NLP, and machine learning capabilities to improve testing.</p>




      





<div id="article_bottom_promo">
  
  
  <br><center>
<a href="/user/register/?destination=/user/mailing_list/" target="_blank"><img src="https://demo.idg.com.au/arn/ARNSurvey.png" width="280"></img></a>
</center>
  
</div>




      

        
      





<aside class="readmore" id="brand-post-in-article-promo">
  <div class="nocontent">
  <a class="image placeholder" href="/brand-post/content/678920/a-look-inside-the-comprehensive-remote-training-and-certifications-options-now-available-via-the-aws-partner-network/" onclick="trackBrandPostNativeAdLink(678920);">
    <img src="https://d1abomko0vm8t1.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/training-and-cert_logo_color_1.png" />
  </a>

  <span class="text">
    <img class="brandpost_logo" src="https://d1abomko0vm8t1.cloudfront.net/dimg/90x30/brand_post/post_type/brandpost_type.png">
    <a href="/brand-post/content/678920/a-look-inside-the-comprehensive-remote-training-and-certifications-options-now-available-via-the-aws-partner-network/" onclick="trackBrandPostNativeAdLink(678920);">A look inside the comprehensive remote training and certifications options now available via the AWS partner network</a><br/>
  </span>

  <a class="more" href="/brand-post/93/amazon-web-services/" onclick="trackBrandPostNativeAdLink(678920);">More from Amazon Web Services</a>

  
  </div>
</aside>




<script type="text/javascript">
$(document).ready(function() {
  if(document.getElementById("brand-post-promo-placeholder-slot") !== null) {
    insertBrandPostReadMoreSlot();
  } else {
    insertBrandPostArticleMiddle();
  }
});

function insertBrandPostReadMoreSlot() {
  $('#brand-post-promo-placeholder-slot').replaceWith($('#brand-post-in-article-promo'));
}

function insertBrandPostArticleMiddle() {
  var pos = $('article.full .body > .storybody').length;
  if (pos > 5) {
    pos = Math.round(pos / 2);
  }
  
  $('article.full .body > .storybody').each(function(index, object){  
    if (index == pos) {
      $(this).after($('#brand-post-in-article-promo'));
    }
  });
}
</script>




<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>



      


      
      

      
      <section class="art-connect">
	<div class="art-connect_social">
		<h3>Follow Us</h3>
		<ul class="art-connect_social_links"><li><a class="art-connect_social_icon art-connect_twitter" href="https://twitter.com/arnnet" target="_blank">Twitter</a></li><li><a class="art-connect_social_icon art-connect_linkedin" href="https://www.linkedin.com/grp/home?gid=3593508" target="_blank">LinkedIn</a></li></ul>
	</div>

	

<div class="qs-article_widget">
  <h3>Join the  newsletter!</h3>
  <!-- <small></small> -->

  <form id="qs-article" action="/newsletter/quick-subscription/">
    
    <input type="hidden" name="newsletter" value="466042" id="id_newsletter" />
    <input type="hidden" value="https://www.reseller.co.nz/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/" name="signup_url">

    

    <div class="qs-anonymous" id="qs-anonymous">
      <input type="email" name="email" required placeholder="Email address" class="qs-textfield" id="id_email" />
      <button type="button" class="qs-btn primary" id="qs-btn_anonymous">Join</button>
    </div>
    <div class="g-recaptcha" data-sitekey="6LdpMvcUAAAAALap2TX-ZdIiK0lEU8BMz3moXq7T"></div>

    <!-- email signup section end -->

    <div class="reg-or">
      <span>Or</span>     
    </div>

    <!-- social media signup section -->
    <div id="social-login-wrap">
      <div id="social-login-con">
        <ul>
          <li>
            <a class="reg-linkedin_link" href="/social/login/linkedin-oauth2/?next=/user/mailing_list/">
              <span >
                <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg>
              </span>
              Sign in with LinkedIn
            </a>
          </li>
          <li>
            <a class="reg-facebook_link" href="/social/login/facebook/?next=/user/mailing_list/">
              <span>
                <svg xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg>
              </span>
              Sign in with Facebook
            </a>
          </li>
        </ul>
      </div>
    </div>
    <!-- social media signup section -->

    <div id="qs-terms">
      <p>Sign up to gain exclusive access to email subscriptions, event invitations, competitions, giveaways, and much more.</p>
      <p>Membership is free, and your security and privacy remain protected. View our <a href="/privacy/">privacy policy</a> before signing up.</p>
    </div>
  </form>

  <div class="qs-message" id="qs-message">Error: Please check your email address.</div>
</div>

<script type="text/javascript">
$(document).ready(function() {
  var wrap = $('.qs-article_widget');
  wrap.css('background', wrap.data('color-initial'));
  
  var form = $('#qs-article');
  
  $('#qs-btn_change_email').click(function() {
    $('#qs-registered').slideUp();
    $('#qs-anonymous').slideDown();
  });
  
  $('#qs-btn_anonymous, #qs-btn_registered', form).click(function() {
    form.submit();
  });
  
  // $("#qs-message").click(function() {
  //   $(this).fadeOut();
  // });
  
  form.submit(function(e) {
    e.preventDefault();
    
    var data = {};
    $('#qs-article').serializeArray().map(function(x) {
      data[x.name] = x.value;
    });
    
    $('#qs-message').hide();
    
    $.ajax({
      url: form.attr('action'),
      type: 'POST',
      dataType: 'json',
      data: data,
      error: function(xhr) {
        var data = JSON.parse(xhr.responseText);
        alert(data.message);
      },
      success: function(data) {
        if (data.success) {
          $('#id_email', form).val('');
          // wrap.css('background-color', wrap.data('color-success'));
          // $('#qs-message').css('color', wrap.data('color-success'));
          $('#qs-registered, #qs-anonymous').slideUp();
        }
        $('#qs-message').html(data.message).slideDown();
      }
    });
  });
});
</script>


</section>

      


        
      
      <p class="tags">
        Tags <a href="/tag/machine-learning/">machine learning</a><a href="/tag/analytics/">analytics</a><a href="/tag/data/">data</a><a href="/tag/automation_2/">Automation.</a>
      </p>
      
      
      
      



      
<aside class="art-readnext readnext">
	<h2 class="lo-title center">Read next</h2>
	<ul>
		
		
		
		<li>
			
			
	        

			<a class="image" href="/article/692338/aruba-switch-can-cut-need-separate-single-function-appliances/"><img src="https://d1abomko0vm8t1.cloudfront.net/article/images/300x300/dimg/dreamstime_s_155254129_5.jpg"></a>
			<h3><a href="/article/692338/aruba-switch-can-cut-need-separate-single-function-appliances/">Aruba switch can cut the need for separate, single-function appliances</a></h3>

			

		</li>
		
		<li>
			
			
	        

			<a class="image" href="/article/692357/cyber-security-outfit-cybercx-merges-kiwi-subsidiary-insomnia-security/"><img src="https://d1abomko0vm8t1.cloudfront.net/article/images/300x300/dimg/john_paitaridis.jpg"></a>
			<h3><a href="/article/692357/cyber-security-outfit-cybercx-merges-kiwi-subsidiary-insomnia-security/">Cyber security outfit CyberCX merges with Kiwi subsidiary Insomnia Security</a></h3>

			

		</li>
		
		

		
		
		
		
		<li class="gallery">
			<a class="image" href="/slideshow/689839/meet-inspiring-female-front-runners-honoured-reseller-news-women-ict-awards/"><img src="https://d1abomko0vm8t1.cloudfront.net/article/images/190x190/dimg/236_6.jpg"></a>
			<h3><a href="/slideshow/689839/meet-inspiring-female-front-runners-honoured-reseller-news-women-ict-awards/">Meet the inspiring female front runners honoured at Reseller News Women in ...</a></h3>
		</li>
		
		
		
	</ul>
</aside>



      </div><!-- body -->

    </article>


    <div class="art-sidebar">
      
      

  
  <aside class="rhs-follow-us">
    <h2 class="lo-title">Follow us</h2>
    <ul class="">
      <li class="twitter"><a href="https://twitter.com/ResellerNewsNZ" target="_blank" title="Twitter">Twitter</a></li>
      <li class="facebook"><a href="https://www.facebook.com/NZResellerNews" target="_blank" title="Facebook">Facebook</a></li>
      <li class="linkedin"><a href="https://www.linkedin.com/company/reseller-news/" target="_blank" title="LinkedIn">LinkedIn</a></li>
      <li class="rss"><a href="/rss/tax/news/" target="_blank" title="RSS">RSS</a></li>
    </ul>

  </aside>
  

  
  
  <div class="rhs_boombox">
<div class="gpt-ad" id="gpt-ad-right-hand-side-story-list-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
  
  

  <!--  promo unit -->
  
  
  <div class="module-rhs-brandpost">
    <h2 class="lo-title">Events</h2>
    <article id="event-promo">
    
    <div>
      <a class="main-img" href="https://www.reseller.co.nz/innovation_awards/nominations/">
        <img src="https://d1abomko0vm8t1.cloudfront.net/dimg/300x300/promoted_content/promo/innovation-awards-2021-rhs-nz.png">
      </a>
      <h3 class="title">
        <a href="https://www.reseller.co.nz/innovation_awards/nominations/" title="Reseller News Innovation Awards 2021">Reseller News Innovation Awards 2021</a>
      </h3>
      
    </div>
    
    <div>
      <a class="main-img" href="https://www.reseller.co.nz/wiicta">
        <img src="https://d1abomko0vm8t1.cloudfront.net/dimg/300x300/promoted_content/promo/hero-image_wiicta_rn.jpg">
      </a>
      <h3 class="title">
        <a href="https://www.reseller.co.nz/wiicta" title="Women in ICT Awards (WIICTA) 2021">Women in ICT Awards (WIICTA) 2021</a>
      </h3>
      
      <p class="description"> 
        Nominations now closed
      </p>
      
    </div>
    
    </article>
  </div>
  
  <!-- / promo unit -->


  


  
    



<div class="module-rhs-brandpost">
  <h2 class="lo-title">Brand Post</h2>
  <article>
    
    
    <a class="main-img" href="/brand-post/content/678920/a-look-inside-the-comprehensive-remote-training-and-certifications-options-now-available-via-the-aws-partner-network/" onclick="trackBrandPostNativeAdLink(678920);">
      <img src=/dimg/300x300/dimg/dreamstime_xl_155799993.jpg>
    </a>
    
    
    <h3 class="title">
      <a href="/brand-post/content/678920/a-look-inside-the-comprehensive-remote-training-and-certifications-options-now-available-via-the-aws-partner-network/" onclick="trackBrandPostNativeAdLink(678920);">
        A look inside the comprehensive remote training and certifications options now available via the AWS partner network
      </a>
    </h3>
   
    
    <div class="sponsor">
      <span>Sponsored By</span>
      <a href="/brand-post/93/amazon-web-services/" title="Amazon Web Services" onclick="trackBrandPostNativeAdLink(678920);">
          <img src="https://d1abomko0vm8t1.cloudfront.net/brand-post/logo/80x80/brand_posts/brand/training-and-cert_logo_color_1.png"  alt="Amazon Web Services"/>
      </a>
    </div>
  </article>
</div>







<script type="text/javascript">
function trackBrandPostNativeAdLink(nid) {
  ga("send", "event", 'Brand Posts', 'Brand Post native ad click', 'brand-post-nid-' + nid, {'nonInteraction': 1});
}
</script>


  

  

  
  
  

  
  
  

  
  <aside class="rhs_block directory_search dir1" >
    <h2 class="lo-title">Distributor Directory</h2>
    <p class="desc">Your essential guide to New Zealand Distributors</p>
    <ul class="rotate-imgs">
      <li class="hidden">
        <a href="#" class="dir-link"> 
          <img src="" alt="" class="dir-img">
        </a>
      </li>
      <li class="hidden">
        <a href="#" class="dir-link">
          <img src="" alt="" class="dir-img">
        </a>
      </li>
    </ul>
    <form action="/distributor_directory/search" method="get">
      <input placeholder="Search distributors" type="text" name=q size=35 />
      <input type="submit" Value="Search" />
    </form>
    <p class="browse">
      Find distributors by <a class="dist" href="/distributor_directory/by_name">name</a> - 
      <a class="dist" href="/distributor_directory/vendors">vendor</a> -
      <a class="dist" href="/distributor_directory/office_location">location</a>
    </p>
  </aside>
  


  
  <aside class="rhs_block directory_search dir2"  >
    <h2 class="lo-title">Vendor Directory</h2>
    <p class="desc">Your essential guide to New Zealand Vendors</p>
    <ul class="rotate-imgs">
      <li class="hidden">
        <a href="" class="dir-link" > 
          <img src="" alt="" class="dir-img">
        </a>
      </li>
      <li class="hidden">
        <a href="" class="dir-link" >
          <img src="" alt="" class="dir-img">
        </a>
      </li>
    </ul>
    <form action="/vendor_directory/search/" method="get"><input type='hidden' name='csrfmiddlewaretoken' value='Epsn2ilLcZkszwFB3h02ygNIKlqWbkObEZhTogO55mg44idZW1cP4IrNfG7tMbu0' />
      <input placeholder="Search vendors" type="text" name="q" size="35" />
      <input type="submit" value='Search' />
    </form>
    <p class="browse">
      Find vendors by <a class="dist" href="/vendor_directory/by_name/">name</a> -
      <a class="dist" href="/vendor_directory/">category</a> 
    </p>
  </aside>
  

  
  <aside>
    <h2 class="lo-title">Microsites</h2>
    <ul class="related_list whitepapers">
        <li>
          <a class="image" href="/microsoft-office/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211021182430" data-src="https://demo.idg.com.au/zones/microsoft-office/ms-logo.png" /></a>
          <h3><a href="/microsoft-office/">From desktop to web and everything in between, Microsoft Office delivers the help you need to work anytime, anywhere. Pick the Office that's right for you.</a></h3>
        </li>
    </ul>
  </aside>
  

  
<section class="lo-rhs_upcoming">
	
	

<h2>Featured</h2>
<ul class="lo-event_promos">

</ul>

	
</section>
<section class="lo-rhs_slideshows">
	<h2 class="lo-title">Slideshows</h2>

	
	
	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211019181712" data-src="https://d1abomko0vm8t1.cloudfront.net/dimg/540x540/dimg/236_6.jpg" alt="Meet the inspiring female front runners honoured at Reseller News Women in ICT Awards">
    <header class="lo-slideshow_header">
        
        
        
        <h3 class="lo-slideshow_title">Meet the inspiring female front runners honoured at Reseller News Women in ICT Awards</h3>
        <p class="lo-slideshow_summary">​Reseller News is proud to showcase the winners, highly commended and finalists of the new-look Women in ICT Awards (WIICTA) in 2021, setting a new industry benchmark for female achievement and accomplishment in New Zealand.</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/689839/meet-inspiring-female-front-runners-honoured-reseller-news-women-ict-awards/">Meet the inspiring female front runners honoured at Reseller News Women in ICT Awards</a>
    
    
</article>


	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211019181712" data-src="https://d1abomko0vm8t1.cloudfront.net/dimg/540x540/dimg/099_10.jpg" alt="Record-breaking channel crowd honours female excellence at Reseller News Women in ICT Awards">
    <header class="lo-slideshow_header">
        
        
        
        <h3 class="lo-slideshow_title">Record-breaking channel crowd honours female excellence at Reseller News Women in ICT Awards</h3>
        <p class="lo-slideshow_summary">The new-look Women in ICT Awards honoured female excellence within the technology channel following an industry-defining celebration in New Zealand, played out in front of more than 310 attendees at Hilton Auckland.</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/689743/record-breaking-channel-crowd-honours-female-excellence-reseller-news-women-ict-awards/">Record-breaking channel crowd honours female excellence at Reseller News Women in ICT Awards</a>
    
    
</article>


	
	


<article class="lo-slideshow">
    
       
    <img class="lo-slideshow_image lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211019181712" data-src="https://d1abomko0vm8t1.cloudfront.net/dimg/540x540/dimg/026_20.jpg" alt="Channel leaders unite at Reseller News Influencer Network">
    <header class="lo-slideshow_header">
        
        
        
        <h3 class="lo-slideshow_title">Channel leaders unite at Reseller News Influencer Network</h3>
        <p class="lo-slideshow_summary">Leading executives within the Kiwi channel united under one roof as Reseller News launched a market-leading agenda at the inaugural Influencer Network in Auckland.</p>
    </header>
    <a class="lo-slideshow_link" href="/slideshow/688292/channel-leaders-unite-reseller-news-influencer-network/">Channel leaders unite at Reseller News Influencer Network</a>
    
    
</article>


	
	

</section>


  
  
  
  


  
  
  <div class="rhs_block rhs_boombox">
    <div class="content">
<div class="gpt-ad" id="gpt-ad-right-hand-side-boombox-standard-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

 </div>
  </div>
  
  

  
  

  



	

<aside>
	<h2 class="lo-title">Related Whitepapers</h2>
	<ul class="related_list whitepapers">
	
	</ul>
</aside>




      
    </div>



    <div class="art-extra">

    
    <div class="art-comments" id="art-comments_692260">
    <a class="art-comment_show" data-disqus-identifier="/article/692260/" data-disqus-shortname="resellernz" href="#">Show Comments</a>
<div id="disqus_thread" data-disqus-shortname="resellernz" data-disqus-identifier="/article/692260/"></div>
<script type="text/javascript">
var disqus_shortname = 'resellernz';
var disqus_identifier = '/article/692260/';
var disqus_init = false;
function disqus_config() {
	this.callbacks.onReady = [function() {
		if (disqus_init) return;
		disqus_init = true;

		if ($('.art-articles_wrap_infinite').length == 0) return;

		var comment_text = $('.art-comment_show').first().text();
		if (comment_text == '0 Comments') {
			$(".art-comment_show_activated").removeClass("art-comment_show_activated");
			$('#disqus_thread').hide();
		}
	}];
}

(function() {
	$('.art-comment_show').first().addClass('art-comment_show_activated');
	var dsq = document.createElement('script'); dsq.type = 'text/javascript'; dsq.async = true;
	dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
	(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>

    </div>
      



      

      
      <div class="lo-bottom_boombox bottom_boombox">
      
<div class="gpt-ad" id="gpt-ad-main-column-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[300, 250], [300, 600]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 600], [[300, 600], [300, 250]]], [[0, 0], [[300, 250]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>


      </div>
      


      <!-- <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/article.js?release=20211021182430"></script> -->

      



      
<script type="text/javascript">
(function() {
  var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
  po.src = 'https://apis.google.com/js/plusone.js';
  var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
})();
</script>



    </div>

    


    
    
    <div id="leaderboard-bottom-ad" class="art-bottom_leaderboard lo-leaderboard_bottom">
<div class="gpt-ad" id="gpt-ad-bottom-banner-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>  
    
    


    
    



<div class="ias-pagination" id="ias-pagination_692260">
	<a class="ias-next" data-sms="Hires former Okta and AT&amp;T talent Graham Pearson." data-image="https://d1abomko0vm8t1.cloudfront.net/dimg/200x200/dimg/graham_pearson_anz_vp__md_lacework_2_1.jpg" title="Cloud security vendor Lacework expands into A/NZ" data-article-nextid="692117" href="/article/692117/cloud-security-vendor-lacework-expands-into-nz/">Cloud security vendor Lacework expands into A/NZ</a>
</div>

    

    
    <div id="clarity-context-data_692260" data-context="{&quot;event_type&quot;: &quot;pageview&quot;, &quot;tags&quot;: [&quot;machine learning&quot;, &quot;analytics&quot;, &quot;data&quot;, &quot;Automation.&quot;], &quot;author&quot;: &quot;Isaac Sacolick&quot;, &quot;word_count&quot;: 1005, &quot;publication_datetime&quot;: &quot;2021-10-18T18:45:00+00:00&quot;, &quot;score&quot;: 1, &quot;content_type&quot;: &quot;article&quot;, &quot;content_id&quot;: 965714855}">

    



  </div><!-- art-wrap -->




</div><!-- art-articles_wrap -->










  </div><!-- site_columns_main -->
  





  <div class="clearing">&nbsp;</div><!-- This is for NN6 -->
  </div><!-- threecolumns -->
    
    <div id="ad-bottom" class="lo-leaderboard_bottom">
    <div id="leaderboard-bottom-padding">
    <div id="leaderboard-bottom">
      <div id="leaderboard-bottom-ad">
<div class="gpt-ad" id="gpt-ad-bottom-banner-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[728, 90]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[728, 90], [[728, 90]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>

</div>
    </div>
    </div>
    </div>
    











</div><!-- main -->



</div><!-- skin -->

<footer class="lo-footer">
  <div class="lo-footer_content">
    <img class="lo-footer_idg" src="https://demo.idg.com.au/idg_logo_footer.gif" alt="">
    <div class="lo-footer_text">
      <p class="lo-footer_copyright">Copyright 2021 IDG Communications. ABN 14 001 592 650. All rights reserved. Reproduction in whole or in part in any form or medium without express written permission of IDG Communications is prohibited.</p>
      <div class="lo-footer_audit">
      <a href="http://www.auditbureau.org.au/edata/masthead/show/arn" target="_blank"><img src="https://demo.idg.com.au/idg/ABA_audited_website.gif" alt="ABA Audited Website"></a>
      </div>
      <p class="lo-footer_site">
      IDG Sites:
      <a href="http://www.pcworld.co.nz/">PC World New Zealand</a> |
      <a href="http://cio.com/nz/">CIO New Zealand</a> |
      <a href="http://www.computerworld.com/nz/">Computerworld New Zealand</a>
      </p>                                              
      <p class="lo-footer_links">
      Links: <a href="/privacy">Privacy Policy [Updated 13 Sep 19]</a> <span class="cmpSettings cmpReshowLink" style="display:none;"> |<!--injected--> </span> | <a href="https://idg.com.au/reprint/">Reprints</a> | <a href="http://www.idg.com.au/contacts">Advertising</a> | <a href="/books/">Books</a> | <a href="/downloads/">Downloads</a>
      </p>
    </div>
  </div>
</footer>
<div class="lo-script">
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/arn.js?release=20211021182430"></script>
<script type="text/javascript" language="JavaScript" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/lazysizes.min.js?release=20211021182430"></script>

<div id="fb-root"></div>
<script>
	window.fbAsyncInit = function() {
		FB.init({appId: '105374282841262', status: true, cookie: true,
			xfbml: true});
	};
	(function() {
		var e = document.createElement('script'); e.async = true;
		e.src = document.location.protocol + '//connect.facebook.net/en_US/all.js';
		document.getElementById('fb-root').appendChild(e);
	}());
</script>

<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/arn/js/rhs/directory_search.js?release=20211021182430" defer></script>
<script src="https://www.idgcdn.com.au/compressor-staticfiles/arn_zones/nextdc_hub/slick.min.js?release=20211021182430" type="text/javascript"></script>
<script>
	$(document).ready(function(){
		$('#event-promo').slick({
			slidesToShow: 1,
      slidesToScroll: 1,
      infinite: true,
      speed: 500,
      fade: true,
      cssEase: 'linear',
      arrows: false,
      dots: true,
      autoplay: true,
      autoplaySpeed: 3000
		});
	});
</script>
<script>
  
  $(function() {
    if (typeof $.fn.lazyload === 'undefined' ) {
      if ('loading' in HTMLImageElement.prototype) {
          const images = document.querySelectorAll('img[loading="lazy"]');
          images.forEach(img => {
            img.src = img.dataset.original;
          });
      }
      else {
        $.getScript('https://www.pcworld.com/www/js/jquery/jquery.lazyload.min.js',function(){
           $("img.lazy").lazyload({ 
              effect : "fadeIn", 
              threshold: 200,
              failure_limit:25
           });
        });
      }
    }
  });
  
  </script>


  
  <script>
    var disqus_shortname = "";
  </script>
  <script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery.magnific-popup.min.js?release=20211021182430"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/jquery-ias.min.js?release=20211021182430"></script>
  <script src="https://www.idgcdn.com.au/compressor-staticfiles/article/infinitescroll.js?release=20211021182430"></script>
  <script>
    ias_init('Reseller News');
  </script>

<div id="trackers">


<!-- Start Google Analytics  -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-42216900-5', 'auto');

ga('require', 'displayfeatures'); // enables demographics and interests reports


	ga('set', 'dimension1', "none");



	ga('set', 'dimension2', "isaac-sacolick");



	ga('set', 'dimension3', "none");



	ga('set', 'dimension4', "none");



	ga('set', 'dimension5', "anonymous");



	ga('send', 'pageview');


// pageTracker._trackPageLoadTime();


// event tracking is asynchronous
function trackEvent(category, action, label, value) {
	if (value)
		ga('send', 'event', category, action, label, value, {'nonInteraction': 1});
	else
		ga('send', 'event', category, action, label, {'nonInteraction': 1});
}



trackEvent('Content Tags', 'Tag Impression', 'machine learning');

trackEvent('Content Tags', 'Tag Impression', 'analytics');

trackEvent('Content Tags', 'Tag Impression', 'data');

trackEvent('Content Tags', 'Tag Impression', 'automation.');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-678920');

trackEvent('Brand Posts', 'Brand Post native ad impression', 'brand-post-nid-678920');



</script>
<!-- End Google Analytics -->



</div>


<div id="ad_slot"></div>


<div class="ad_scripts">

<div class="gpt-ad" id="gpt-ad-skin-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[1600, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 100], [[1600, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-over-the-page-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[1, 1]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], [[1, 1]]], [[0, 0], []]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-third-party-otp-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[15, 15]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[15, 15]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>




<div class="gpt-ad" id="gpt-ad-mobile-floating-banner-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[320, 50]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[600, 800], []], [[0, 0], [[320, 50]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-mobile-otp-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[2, 2]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[610, 610], []], [[0, 0], [[2, 2]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>



<div class="gpt-ad" id="gpt-ad-teads-inread-608235" data-gpt-ad-unit-path="/8456/IDG.AU_B2B_Reseller.co.nz/software_section" data-gpt-sizes="[[18, 18]]" data-gpt-targeting='{&quot;node&quot;: [&quot;692260&quot;], &quot;idgau_tax&quot;: [&quot;news&quot;], &quot;site&quot;: [&quot;nzrn&quot;], &quot;sect&quot;: [&quot;software&quot;], &quot;idgau_search_referrer&quot;: [&quot;no&quot;], &quot;type&quot;: [&quot;article&quot;]}' data-gpt-size-mapping="[[[0, 0], [[18, 18]]]]">
</div>
<div class="house-slot" style="display:none" data-name="" data-min-width="">

</div>




<script type="text/javascript" src="https://www.idgcdn.com.au/compressor-staticfiles/adsmin/idg_gpt.js?release=20211021182430" charset="utf-8"></script>
<script type="text/javascript">
createAndDisplayAds();
</script>
</div>


<div class="load_dropcontent" id="load_dropcontent">
  <div class="latest" data-load="sub_news_latest">
    
    <h2>Latest News</h2>
    <dl>
      
      
        
          <dt>04:00PM</dt>
          <dd><a title="Server-side request forgery attacks explained and how to defend against them" href="/article/692363/ssrf-attacks-explained-how-defend-against-them/">Server-side request forgery attacks explained and how to defend against them</a></dd>
        
          <dt>Oct 19</dt>
          <dd><a title="3 ways to use data, analytics and machine learning in test automation" href="/article/692260/3-ways-use-data-analytics-machine-learning-test-automation/">3 ways to use data, analytics and machine learning in test automation</a></dd>
        
          <dt>06:30AM</dt>
          <dd><a title="Global IT spending to top $4T in 2022, according to Gartner" href="/article/692380/global-it-spending-top-4t-2022-according-gartner/">Global IT spending to top $4T in 2022, according to Gartner</a></dd>
        
          <dt>03:02AM</dt>
          <dd><a title="Even Raspberry Pi isn’t immune to the chip shortage" href="/article/692376/even-raspberry-pi-isn-t-immune-chip-shortage/">Even Raspberry Pi isn’t immune to the chip shortage</a></dd>
        
        <dt></dt>
        <dd><a class="more" href="/tax/news">More News</a></dd>
      
    </dl>
    

    
    



<ul class="topstories">
	
	<li>
		<a class="image" href="/article/692378/acc-signs-up-cornerstone-customer-microsoft-nz-datacentre-region/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211019181712" data-src="https://d1abomko0vm8t1.cloudfront.net/promoted-content/image/180x120/dimg/36nz-post-peter-fletcher-2.jpg"></a>
		<h3><a href="/article/692378/acc-signs-up-cornerstone-customer-microsoft-nz-datacentre-region/">ACC signs up as cornerstone customer for Microsoft&#39;s NZ datacentre region</a></h3>
	</li>
	
	<li>
		<a class="image" href="/article/692385/vodafone-nz-claims-microsoft-gold-security-badge/"><img class="lazyload" src="https://www.idgcdn.com.au/compressor-staticfiles/lazysizes/placehold.png?release=20211019181712" data-src="https://d1abomko0vm8t1.cloudfront.net/promoted-content/image/180x120/dimg/glenn-johnstone-vodafone.jpg"></a>
		<h3><a href="/article/692385/vodafone-nz-claims-microsoft-gold-security-badge/">Vodafone NZ claims Microsoft Gold security badge</a></h3>
	</li>
	
</ul>


    
  </div>

  <dl class="latest" data-load="sub_events_latest">
    
    
    
    <h2>Reseller News Events</h2>
    
    <dt>19 Nov</dt>
    <dd>
    
    <a title="Reseller News Innovation Awards 2021" href="https://www.reseller.co.nz/innovation_awards/">Reseller News Innovation Awards 2021</a>
    
    </dd>
    
    <dt>25 Nov</dt>
    <dd>
    
    <a title="Pulse Check | Virtual EDGE" href="https://www.reseller.co.nz/pulse-check/">Pulse Check | Virtual EDGE</a>
    
    </dd>
    
    
    

    
    
    

    <dd><a class="more" href="/events/upcoming/">View all events</a></dd>
    
  </dl>

  <div class="hotevents" data-load="sub_events_hotevents">
    
    

<h2>Featured</h2>
<ul class="lo-event_promos">

<li>
<article class="lo-event_promo">
	<a class="lo-event_promo_image" href="https://www.arnnet.com.au/pulse-check/">
		<img src="https://d1abomko0vm8t1.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/pulsecheck250x100_1.png" alt="Pulse Check">
		<p class="lo-event_promo_summary">Pulse Check</p>
	</a>
	<h3 class="lo-event_promo_title"><a href="https://www.arnnet.com.au/pulse-check/">Pulse Check</a></h3>
</article>
</li>

<li>
<article class="lo-event_promo">
	<a class="lo-event_promo_image" href="https://www.reseller.co.nz/innovation_awards/">
		<img src="https://d1abomko0vm8t1.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/innovation-awards-2021-featured.png" alt="Reseller News Innovation Awards">
		<p class="lo-event_promo_summary">Reseller News Innovation Awards</p>
	</a>
	<h3 class="lo-event_promo_title"><a href="https://www.reseller.co.nz/innovation_awards/">Reseller News Innovation Awards</a></h3>
</article>
</li>

<li>
<article class="lo-event_promo">
	<a class="lo-event_promo_image" href="https://www.reseller.co.nz/wiicta/">
		<img src="https://d1abomko0vm8t1.cloudfront.net/promoted-content/image/250x100/promoted_content/promo/rn-hero-site-wiicta.png" alt="Reseller News WIICTA 2021">
		<p class="lo-event_promo_summary">Reseller News Women in ICT Awards</p>
	</a>
	<h3 class="lo-event_promo_title"><a href="https://www.reseller.co.nz/wiicta/">Reseller News WIICTA 2021</a></h3>
</article>
</li>

</ul>

    
  </div>
</div>

<script>
  $('#load_dropcontent [data-load]').each(function() { $("[data-placeholder="+$(this).data('load')+"]").replaceWith(this); });
</script>


<script type="text/javascript">
var disqus_shortname = 'resellernz';

/*
(function () {
var s = document.createElement('script'); s.async = true;
s.type = 'text/javascript';
s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
}());
*/

// This lets us know when the JS has loaded and after the counts are fetched.
function disqus_counts_loaded() {
	DISQUSWIDGETS.old_displayCount = DISQUSWIDGETS.displayCount;

	// Override the old displayCount() with a new one so we can attach our helper onto it.
	DISQUSWIDGETS.displayCount = function(arg) {
		DISQUSWIDGETS.old_displayCount(arg);
		$("a[href$=#disqus_thread],*[data-disqus-identifier]").trigger('disqus-counts-loaded');
	}
}

$.getScript('//' + disqus_shortname + '.disqus.com/count.js', disqus_counts_loaded);
</script>




<!-- Crazy Egg Tracking -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0018/8767.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>



<!-- Twitter universal website tag code -->
<script>
!function(e,n,u,a){e.twq||(a=e.twq=function(){a.exe?a.exe.apply(a,arguments):
a.queue.push(arguments);},a.version='1',a.queue=[],t=n.createElement(u),
t.async=!0,t.src='//static.ads-twitter.com/uwt.js',s=n.getElementsByTagName(u)[0],
s.parentNode.insertBefore(t,s))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','nv5jw');
twq('track','PageView');
</script>
<!-- End Twitter universal website tag code -->

<!-- Taboola Pixel Code -->
<script type='text/javascript'>
  window._tfa = window._tfa || [];
  window._tfa.push({notify: 'event', name: 'page_view', id: 1009432});
  !function (t, f, a, x) {
         if (!document.getElementById(x)) {
            t.async = 1;t.src = a;t.id=x;f.parentNode.insertBefore(t, f);
         }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/unip/1009432/tfa.js',
  'tb_tfa_script');
</script>
<noscript>
  <img src='//trc.taboola.com/1009432/log/3/unip?en=page_view'
      width='0' height='0' style='display:none'/>
</noscript>
<!-- End of Taboola Pixel Code -->


<script type="text/javascript"> _linkedin_data_partner_id = "186603"; </script>
<script type="text/javascript"> 
    (function(){
        var s = document.getElementsByTagName("script")[0]; 
        var b = document.createElement("script"); 
        b.type = "text/javascript";
        b.async = true; 
        b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js"; 
        s.parentNode.insertBefore(b, s);
    })(); 
</script> 
<noscript>
    <img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=186603&fmt=gif" />
</noscript>




<script type="text/javascript">
  var clarity_tracking_starter = function (override_context_data) {
    var d=document;
    var id = 'idg-tracking';
    var s='script';
    var js, fjs = d.getElementsByTagName(s)[0];

    if (d.getElementById(id)) {
      runClarity();
      return false
    }
    
    js = d.createElement(s); 
    js.id = id; 
    js.type = "text/javascript";
    js.onload = function () {runClarity()};
    js.src = "https://www.idgcdn.com.au/compressor-staticfiles/clarity/idg_clarity.js?release=20211021182430";
    fjs.parentNode.insertBefore(js, fjs);

    function runClarity(){
      var dynamic_key_val_api = "/script-tagger/clarity/json/";
      var first_page_context_data = {
        'event_type':"pageview",'tags':["machine learning", "analytics", "data", "Automation."],'author':"Isaac Sacolick",'word_count':1005,'publication_datetime':"2021-10-18T18:45:00+00:00",'score':1,'content_type':"article",'content_id':965714855
      }

      // Context data can be overridden and is used on infinite scroll pages to pass in 
      // context of the new article that is loaded on the page.
      var context_data = override_context_data || first_page_context_data;

      clarity_logger.init(
        dynamic_key_val_api,
        'https://clarity-api-prod.idg.com.au/collect/client', 
        context_data
      );
    }
  };
</script> 



</div>
</body></html>
